Recent Topics

1 Jan 22, 2021 04:02    

I am getting the error that my database schema is not up to date. The install failed in the middle and I got these errors:

Fatal error: Uncaught Error: Call to undefined function include_js_vars() in /hermes/walnacweb04/walnacweb04am/b2542/pow.paulleslie/htdocs/b2e_2018/skins_adm/ Stack trace: #0 /hermes/walnacweb04/walnacweb04am/b2542/pow.paulleslie/htdocs/b2e_2018/skins_adm/_adminUI_general.class.php(714): require() #1 /hermes/walnacweb04/walnacweb04am/b2542/pow.paulleslie/htdocs/b2e_2018/skins_adm/bootstrap/_adminUI.class.php(224): AdminUI_general->disp_global_footer() #2 /hermes/walnacweb04/walnacweb04am/b2542/pow.paulleslie/htdocs/b2e_2018/inc/maintenance/upgrade.ctrl.php(668): AdminUI->disp_global_footer() #3 /hermes/walnacweb04/walnacweb04am/b2542/pow.paulleslie/htdocs/b2e_2018/evoadm.php(224): require('/hermes/walnacw...') #4 {main} thrown in /hermes/walnacweb04/walnacweb04am/b2542/pow.paulleslie/htdocs/b2e_2018/skins_adm/ on line 66

I tried to restore the database but got a schema error:

"This is b2evolution version 7.2.2-stable.
You cannot use the application before you finish configuration and installation.
Database schema is not up to date!
You have schema version «16010», but we would need «16170».
Please use the installer to finish your configuration/installation now."

I have tried with both DBs to go to the install but get an internal server error.

Can you help?

2 Jan 23, 2021 17:49

Do you have a copy of the database before your upgrade atempt?

When you say you tried to restore the database, how exactly did you try that?

And you say you tried with both databases, so you have two?

Can you confirm they are sql files on your computer or what and where are they.

Further can you tell the difference from them i.e which version they are and how can you tell?

Hope all that is not too demanding :)

3 Jan 24, 2021 18:06

Sorry it's not clear \enough for me what you are doing.

"Hi, Well, I have uploaded a clean install and imported a copy of my mysql database backup, then opened the install with my existing back-up database. I copied over my media folder, and then changed all the skins to the Bootstrap skin. The site opened ( but I am getting the following error on every page:"

If you imported a database then you have no choice but the just install be default the imported database so why say you opened the install with 'my existing backup? What choice did you have? Or did you mention the same database twice.

You are also not clarifying which version of b2evo you are doing this with. For example the backup database would be for the old b2evolution.

So rather than answering my queries you have just another load of work that isn't clear to me, so I don't see how I can help without even more questions :(

4 Jan 25, 2021 18:57

OK I have a better idea of what you did but not enough info for my thinking, so i'll tell you what i have done on occasion.

I regularly keep a non zipped backup of the database as an SQL file by exporting from phpMyAdim via cpanel

Then if anything goes wrong, I ftp all the files of say b2evo6.11.7 that i was using when i backed up the database.

Then I drop all the tables from the database via phpMyAdmin and import the old SQL file.

This doesn't directly address your issue but it is so important to match the blog engine and database versions I start again from the previous working setup.

You can find the database version by reading the value in the database via Settings

I also have page to correlate database and b2evo version numbers
Ignore the not working part, that's just my site info that hasn't been updated.

So I hope this clarifies why I'm not sure of your efforts.

5 Jan 26, 2021 04:05

Well, I discovered that B2E does not work properly on PHP 7.4. I had listed my version as 7.3.2, but my hosting service put it up to 7.4. SO, I was getting all those errors. As soon as I put it back to 7.3, it seems to work.

I also removed some old themes and widgets and now it all seems fine.


This post has 4 feedbacks awaiting moderation...

This thread is resolved.

Form is loading...