Recent Topics

Could not get hash salt from server

Started by on Dec 27, 2018 – Contents updated: Dec 28, 2018

Dec 27, 2018 21:12    

Could not get hash salt from server

Hi
Earlier this year I got an SSL certificate installed for my site - site isn't always fully secure which my hosting company says was down to having a number of http: links within my site. So i altered as many of these as i could to https including my blog. Today I upgraded to 6.10.5 but did not do a back up as I had exceeded to number of backup. My blog works fine until i went to log in to add a new post then i get an error message about hash salt.(see attached file) A search for this error did link back to a thread on these forums - https://forums.b2evolution.net/can-t-log-in-hash-salt but none of thee proposed solutions worked for me. I cannot log in from the link on the blog(see attached) and I thought requesting a new password might sort the problem but I cannot do that either I am not even sure this is a fault with your software of if it's a host thing linked to the SSL - i am posting here due to the previous thread.
Regards

Could not get hash salt from server
Affected website URL :https://edgeworthstown.net/blog/admin.php
Exact b2evolution version number :6.10.5
Name of your webhost :arvixe.com

Dec 28, 2018 13:17

Hi Not sure if this will be of any use but I suppose may bring some focus to this issue.

  1. I suppose you've checked the baseurl in [/config/_basic.confog.php]
  2. and have set Settings > URLs to Allow both HTTP and HTTPs
  3. Have you checked the database

    the value of [blog_siteurl] in table [evo_blogs] was where the redirect was occurring.
    post #15 https://forums.b2evolution.net/request-for-paid-help-borked-update#c111828

In the above there was a setting to http so the https call didn't work

Dec 28, 2018 15:13

Hey thanks so much!!!
I changed the base URL to https and it worked right away,

Thanks again
Happy New year


Form is loading...

Bootstrap CMS – This forum is powered by b2evolution CMS, a complete engine for your website.