Recent Topics

MySQL error on attempt to upgrade

Started by on Sep 09, 2019 – Contents updated: Dec 11, 2019

1 Sep 09, 2019 10:04    

Language / Locale (I have not changed the "English (US) utf-8")

This question: How would you like your b2evolution installed?

has only this error message:

In order to install b2evolution with the en-US locale, your MySQL needs to support the utf-8 connection charset. (mysqli::set_charset(utf8))

All of my collations are UTF_general_ci

What am I supposed to do here?

I was trying to install 7.0.1 beta

2 Sep 09, 2019 20:39

Please show the screenshot of the message, (inc url) Usually there is an option to update to utf8

3 Sep 10, 2019 09:57

I can't. I just rolled back to 6.11.3. I hadn't taken a screen shot. I just followed the Installer link. The text above was all there was on the page. Usually there are choices as to upgrading databases, etc.

4 Dec 09, 2019 08:04

Hey, silly me, I tried it again. Here's the error page

5 Dec 09, 2019 11:35

@drherz
Usually there is an option to set the databse to utf-8 a) during install and b) via phpMyAdmin for example. However I haven't come across a MySQL that doesn't support utf-8 . Have you googled the problem?

6 Dec 09, 2019 12:29

I've been to phpMyAdmin. The collections all indicate UTF_general_ci. A snip of that and the operations tab are attached. There is no choice for a bald UTF-8. There are a bunch of subs, like the utf8_general_ci I have been using, and works fine on the 6 series, or utf_bin.
So as far as I can tell, my PHP already provides the support the program is asking for.

7 Dec 09, 2019 14:08

What version of MySql do you use?

Just to go to basics from my b2evo staus page I'm using [5.5.5-10.2.29-MariaDB-log-cll-lve with utf-8 support] and bevo is set to utf-8

My phpMyAdmin is [utf8mb4_unicode_ci]

and my .config.php setting is [$default_locale = 'en-US';]

All fov v7.01

8 Dec 09, 2019 14:36

Instance name: b2evo
b2evolution version: 6.11.4-stable released on 11/28/19
You are running the latest stable version of b2evolution.
Media directory
OK - /home/. . .public_html/media/ .htaccess
/home/. . . /public_html/.htaccess
Warning: .htaccess differs from sample.htaccess
Install folder Deleted
Internal b2evo charset utf-8
Blog count 14
Caching
Cache directory OK - /home/. . ./public_html/_cache/
Cache folder size 7.2 GB
General caching Enabled
Blog's cache setting. 14 enabled /14 blogs
Time
Server time 12/09/19 - 08:27:10 am
GMT / UTC time 12/09/19 - 01:27:10 pm
b2evolution time 12/09/19 - 08:27:10 am
MySQL
MySQL version 10.3.20-MariaDB
MySQL UTF-8 support Yes

PHP
PHP running as USER: . . .
PHP running as GROUP: . . .
PHP version 7.2.25
PHP register_globals Off
PHP allow_url_include Off
PHP Magic Quotes Off
PHP upload_max_filesize 32M
PHP post_max_size 40M
PHP memory_limit 384M
PHP forced max_execution_time 600 seconds
b2evolution was able to request more time (than the default 30 seconds) to execute complex tasks.
PHP mbstring extension Loaded
PHP XML extension Loaded
PHP IMAP extension Loaded
PHP opcode cache none
Using an opcode cache allows all your PHP scripts to run faster by caching a "compiled" (opcode) version of the scripts instead of recompiling everything at every page load. Several opcode caches are available. We recommend APC (which is included with PHP starting from PHP 7).
PHP user cache none
Using an user cache allows b2evolution to store some cached data (Block Cache) in memory instead of regenerated the blocks at each page load. Several user caches are available. We recommend APCu (which needs to be enabled separately from APC, starting from PHP 7).
GD Library (image handling)
GD Library version
bundled (2.1.0 compatible)
GD JPG Support
Read/Write
GD PNG Support
Read/Write
GD GIF Support
Read/Write
GD FreeType Support
Yes
APIs
REST API OK
XML-RPC OK
AJAX anon_async.php OK
AJAX async.php OK
AJAX action.php OK
AJAX call_plugin.php OK

9 Dec 09, 2019 23:31

I'm at a loss of what to think but think I will :(

10 Dec 10, 2019 20:32

There are two points of interest.
a) b2evo's requirements and
b) a 9some) MySql issues

a)
https://b2evolution.net/downloads/

The Minimum Requirements have changed. You need: PHP 5.6+ / 7.0+ and MySQL 5.5.3+.

https://b2evolution.net/man/system-requirements

MySQL: version 5.1+ for b2evolution v6 or version 5.3.3+ for b2evolution v7. (or MariaDB) InnoDB MUST be enabled (All decent web hosts offer InnoDB)

The two above MySQL versions are not the same ??? (5.5.3 and 5.3.3)
Also InnoDB MUST be enabled

That InnoDB MUST be enabled brings me to
b)
https://mariadb.com/kb/en/library/mariadb-10320-release-notes/

Notable Changes

MDEV-20987: InnoDB fails to start when FTS table has FK relation
See also the release notes for MariaDB 10.3.19 for additional items of note

When upgrading from MariaDB 10.3.8 or earlier to MariaDB 10.3.9 or higher,
running mysql_upgrade is required due to changes introduced in MDEV-14637.

Note I use an older MySQL that doesn't have the above problem 10.2.29

So I wonder if the above is an issue and you could revert o 10.2.29 both 10.2.29 and 10.3.20 are the latest issues of those versions release dates are both 8th Nov 2019.

Hope this is fun?

11 Dec 11, 2019 00:41

I ran into this problem. I went to the Database in Phpmyadmin - <Database in question> Operations.

At the bottom you will see Collations and the character sets
Click the set you want and check "Check all table collations".
Click "GO"


Form is loading...

Open Source CMS – This forum is powered by b2evolution CMS, a complete engine for your website.