Recent Topics

1 Nov 27, 2020 11:33    

I can't get past b2evo 7.1.* as I get the error mentioned in the title. What has changed in the database connection code since then?

The response from my host is

That's showing the error for myself as well, to confirm that is set correctly our end. I'd suggest contacting the developers for the site software as this is 100% correct on PHPMyAdmin

I didn't update a number of domains due to this before and now I thought maybe with the 7.2.2 things may go well but no luck :(

Can someone @fplanque tell me what files/code is used to check the database that gives the error message so I can look at the files etc.

This started on (Aug 05, 2020) ( Yes the update should read 7.1.6 to 7.2.0)

After the problem in EDIT 2 (Aug 15, 2020) I tried again

I didn't worry as it was domain I was happy to use as a test but now I've tried it on [a proper live site] it is more of an issue, as I have had to return to 7.1.6

2 Nov 30, 2020 23:14

b2evolution requires the utf8mb4 charset.

What MySQL calls "utf8" is not the real/full/complete UTF-8 charset.

For example, only utf8mb4 will allow to store unicode emojis.

3 Dec 01, 2020 02:26

Investigating further...

4 Dec 01, 2020 14:25


Yes my phpMyAdmin shows server collection collation as utf8mb4_unicode_ci
all tables the same.

The Server charset: cp1252 West European (latin1) which my host says is the default for a shared service and cannot be changed.

Anyway versions upto 6.11.7 are fine except I have php conflicts such as
[Deprecated: Function get_magic_quotes_gpc() is deprecated in /home/lovejoy/public_html/inc/_core/_param.funcs.php on line 2225]

The strange thing is I did have 7.0.1 working but only after a) fiddling with database and b2evo files and then b) only the next day. My earlier post refer to that oddity but I have not been able to replicate it again.

Thanks again

5 Dec 03, 2020 09:42

Regarding this long term issue, since August. I have always ugrade using ftp as I found the auto usually didn't work and never resolved why, anyway I just moved my last domain to a new host and in doing so spent 2 days sorting problems.

I then thought, what more can go wrong so I decided to update three domains using the auto upgrade, and to my delight even the newly transferred site (b2evo 6.10.5 the lower php5.4 version) when perfectly. Part of my reasoning is that I have fibre to the premises connection, yes out in the woods, so that if I did have to use ftp is would be incredibly quicker.

The only issue now is one remaining domain that has always been a problem ?? So I've deleted the account from the host and will start afresh, and hopefully my next post will be that the next clean install, via ftp will be fine. So 7.2.22 up and running on 3 domains currently.

Thank you for your efforts you especially those behind the scenes.

6 Dec 03, 2020 18:57

Well I'm stuck

I have created a new https account
ftp'd all the 7.2.2 files across
created a new database and get this all to common message:

In order to install b2evolution with the locale, your MySQL needs to support the utf-8 connection charset. (mysqli::set_charset(utf8))

7 Dec 03, 2020 19:38

I cleared the /public_html/ and found my host has a Sotfalculus option to install 7.2.2 so I though I'd do that, but the same error occurs, so I've got them to look at it again, the fifth time since August.

Note the 7.2.2 works fine on other domains on the same host as long as I don't use ftp to transfer a new version ~ it must be upgraded by the b2evo internal option.
The fact that the host can't install it confirms also it's not my use of Filezilla

8 Dec 03, 2020 19:58


As a further update I received this automated message from my host.

To: ~~~~~~~

This is an automated email from Installatron. To unsubscribe from these
emails or to change notification settings, login to your web hosting
control panel, navigate to the Installatron tool, and select the
installed applications you wish to modify.

b2evolution v7.2.2 has failed to install and the details of the failure
have been logged.

Technical error:
Error: A database query has failed. Is the entered database information
correct? Does the account have available disk space?

type = mysql
host = localhost
database = ~~~
username = ~~~~~
password = HIDDEN

Technical information:
method = query
arguments = array ( 0 => 'UPDATE b2_settings SET set_value=? WHERE
set_name=\'default_locale\'', 1 => array ( 0 => 'en_US', ), 2 => NULL,)

errstr =
Technical Error: 1146 Table 'lovejoyorg_b21.b2_settings' doesn't
existUPDATE b2_settings SET set_value='en_US' WHERE

End of report.

I had no problem using ftp up to and including 7.1.6

9 Dec 03, 2020 22:15

Using ftp 7.0.l has the same problem so I've tried 6.11.7 which is fine. ??

and to confirm auto-upgrade to 7.2.2 is fine

so it seems there is an issue in the install.php when invoked either on a clean install or after an ftp overwrite, which would explain why my host using Softaculous can't install either.

I'm sure you can probably emulate this to find the issue if not I am happy to repeat the duff installs as I'm not using the domain currently for any content

10 Dec 04, 2020 14:07

Just to confirm my host has emailed me to say cannot install b2evo 7.2.2 from their inbuilt offering via Sofalculous

11 Dec 10, 2020 16:53


Latest attempt

New database, user, password etc. new ftp upload of 7.2.2

Once all is in place and I access the site, before I invoke the install process, I get this,; Note I have an empty database at this time.

MySQL error:
Then as usual if I try to install

I get the same message if I try to use en-GB i.e. it refers to en-US

Note the only way I can get 7.2.2 is to ftp 6.11.7 then overwrite with 7.2.2

12 Dec 11, 2020 10:53

Last message from host

Thank you for the update.

I can confirm that the DB collation is correct, so this does appear to be an issue with b2evo itself. I would recommend to continue going through the support forums and let us know if they provide any helpful information.

Form is loading...