Recent Topics

RSS Bug in boostrap_blog_skin

Started by on Jul 22, 2019 – Contents updated: Sep 10, 2019

Jul 22, 2019 14:19    

Hello,

I recognized that RSS on bootstrap_blog_skin does not work. (On bricks_skin is works) - So I think this is a matter of boostrap_blog_skin.
Used Browser: Firefox 68.0.1 (64-Bit)
Here is a screenshot:

RSS Bug in boostrap_blog_skin

Jul 22, 2019 15:48

Hi @saunders

Given that you have just edited a file and done other things to that skin (copy and delete a folder), change the name of the skin so it can't be used and import a fresh bootstrap_blog_skin to see if the problem still exists.

How do invoke the rss, is it automatic or can you provide the url where you clicked on link?

I don't know how you got to that page with error.

The error looks simple in that the page should not have spaces at the beginning.

If it works then copy the file before as in the previous topic but do not edit it and see if it works.

Then edit carefully and see what happens

Jul 22, 2019 23:49

I've never used rss and have had it disabaled so it's a bit of a new idea to look at.

What I mean by skin is before the tempskin is invoked by the rss
a) there is the current skin, which is what I ask you to replace due to changes in it
b) where in the current skin do you invoke the rss is it as in the image below

If it is then you can see my query as it is the same 'page' that has the 'Preview' button code hidden.
I want to ensure there was noting in the changes that could have caused this.

Also the URL to the problem isn't really much good without the previous page, which I think is any post on that site where the rss icon sits. So when asking for screen shots it's really important to get the one that is used where the problem arises not just the resulting error.

It all takes that much longer to understand where the problem arises, hence also to back track any changes made to the skin where the problem arose, not the rss skin.

Jul 23, 2019 00:12

Can go back to the original version of the bootstrap_blog_skin before the edit I encouraged, by replacing the whole folder?

Ignore the following for now

I have noticed that the bootstrap skin uses the rss2 temporary skin
I would like to know which brick skin you are using and what rss skin it calls on as
a) it may use the rss skin in which case there could be an issue with the rss2 skin but
b) if it uses the same 'rss2' skin then the problem is with the skin, hence rollback the changes to the skin to gather info on if the changes made for the 'preview' button did this.

The skin info in your first post is inconsistent. The error refers to the rss skin whilst your url refers to the rss2 skin.

So you can see the need for a full screen shot of the browser page of where the problem starts, including the url as well as the full browser page which shows the error.

Jul 23, 2019 10:10

@amoun hmm; try to figure out why the actual bootstrap_blog_skin does not serve rss properly while other skins (e.g. https://fokus.genba.org/?tempskin=_rss2 do a great job) - The problem with rss in bootstrap_blog_skin is an old one. I have had the problems since years, so that bug has nothing to do with your working fix of the preview challenge ;-)

Ok; I deleted the bootstrap_blog_skin, uploaded the skin from the an actual download of 6.11.2 and reinstallted the skin. No change.

What I realized is, that calling an RSS Feed from the widget the URL is different from calling it out of the post for subscribing comments to a special page

This is the URL called by the rss widget:
https://www.npo-consulting.net/blogs/lector.php?tempskin=_atom&disp=comments

This is the URL called by the a pages RSS Llink for comments of that page
https://www.npo-consulting.net/blogs/skins/bootstrap_blog_skin/?disp=comments&p=451

In the first case the rss is called under collection by ?tempskin and in the second one by the skin itself. - Both don't work

Jul 23, 2019 11:10

Thanks for replacing the skin as a test.

I can't test your attempts to use the rss feed without the actual links/buttons you use, hence the requests for the url where you try the actions that result in the URL's you post.

Only by starting where you start can I inspect the code that provides the links whether on the page or via the widget.

But neither of the above URL's you show would work. So where is the link (URL) to page that shows these options? not the links(URLs) the page/widget provide :) You know . . . Monsieur Planque's oft request for 'Proper' screen shots, not clips of the problems

Jul 23, 2019 13:49

@amoun

Before I post some screenshots I want to point out, that this bug probably is not related to a certain skin. I loaded another skin and the bug remained.
What is also showy: The widget of this installation (also 6.11.2) differs from the widget of another installation, because is does not show an option to subscribe an RSS Feed, only _atom and _rdf

So here are the screenshots
1) Customizing

2) Problem by calling the rss feed from the end of a post to subscribe rss for comments

3) Shows the widget (which does not show rss) - in which I don't know how to customize which feeds are allowed to subscribe

PS: Is there a way to set div class="clearfix" for better organizing thumbnails?

Jul 23, 2019 14:21

None of your screen shots show the URL so I can't look at the code behind the problem(s)

A screenshot of whole browser image including the URL, that is was is asked for and directions on how to emulate what you did. Then I can look at the code. :)

So starting with one skin and one installation the idea is to see what you are doing on the page with URL so I can try, and also check the code. It seems there are two ways to invoke the rss 1) by the link on the post and b) by a widget.

I'm only interested in getting the one on the page working first, if that's ok with you. So I don't want any more info on the widget.

Jul 23, 2019 18:04

@amoun sorry I miss the point. In this thread I noticed all URLs I got when calling a rss feed url. Also in the last post in one screenshot you'll find the URL that leads to an error warning of not having a permission to access the server and so on.

You can test it yourself if you call e.g https://www.npo-consulting.net/blogs/notepad.php/the-new-klondike-intoxication-nuggets-in-silicon-valley or any other page.

May be the bug is related to the Stub, because the collections root is something like "notepad.php/" or "pad.php/"

I tried to debug the problem. But there is no debug report only warning pages that it does not work.
So what else URL do you mean ? I have no idea, but as mentioned, may be I miss the point.



That's asthonishing:
When calling the _atom feed of e.g. https://www.npo-consulting.net/blogs/notepad.php by feedly, feedly is able to get the feed (the URL in feedly: https://feedly.com/i/subscription/feed%2Fhttps%3A%2F%2Fwww.npo-consulting.net%2Fblogs%2Fnotepad.php%3Ftempskin%3D_atom) But in case I enter that tail of the URL that belongs to my site (https://www.npo-consulting.net/blogs/notepad.php/tempskin=_atom) the collection does not deliver an rss feed but switches to the start page.Strange
(RSS could not be read by feedly; seems the problem roots in a corrupt RSS command)

Jul 24, 2019 11:25

I am trying to add rss to my site and test it there as I am using 6.11.2
I'll then try different skins and reply.

Ok have applied rss to my site and will deal with my errors on a separate topic, one at a time that will relate to the various errors you have.

Aug 26, 2019 10:04

after Upgrading to 6.11.3 RSS Widget does work again. But nevertheless the RSS Comment Feed in Posts fails.
The screenshot shows, that the bug roots in a false URL. For the working URL I used ?tempskin=_rss2&disp=comments&p=517 taken from another installation where RSS Comment Feed works.
@fplanque is there a fix or should the work around @amoun suggested should be used?

May it be, that this bug depends on another one: In the xml widget there is no rss link, but only atom and rdf (And I can not figure out where to customize this) following a screenshot

PS: Is there a way to add <div class="clearfix"></div> to a comments field, for ordering the images in the post?

Aug 30, 2019 12:36

and here comes an error log message out of server error log:

[Fri Aug 30 12:21:23 2019] [error] [client 77.xxx.xx.xxx] Directory index forbidden by Options directive: /home/.sites/xxx/sitexxx/web/blogs/skins/bootstrap_blog_skin/
[Fri Aug 30 12:21:23 2019] [error] [client 77.xxx.xx.xxx] File does not exist: /home/.sites/383/sitexxx/web/libImage, referer: https://www.npo-consulting.net/blogs/skins/bootstrap_blog_skin/

And another finding: I tried to find out what is meant by "You do not have permission to access the requested file on this server." It referred to Directory Indexing.
So I activated "Directory Indexing" and got this result:

Hope this helps to find and fix the bug

Sep 05, 2019 12:32

@saunders Hello, we investigated your problem and could reproduce when feed skin rss2 is not installed in system because here https://github.com/b2evolution/b2evolution/blob/develop/skins_fallback_v6/_item_feedback.inc.php#L558:

$Item->feedback_feed_link( '_rss2', '<nav class="evo_post_feedback_feed_msg"><p class="text-center">', '</p></nav>', $params['feed_title'] );

we call a feed skin by folder name _rss2.

We fixed code to fallback the requested skin like _rss2 to first found installed feed skin in system. I think on your site the link will be fallback to_atom` skin after update code.
Commit https://github.com/b2evolution/b2evolution/commit/a4dceb70abab1113f66fa7bd9cf97ca21a7becd1.

This post has 1 feedback awaiting moderation...


Form is loading...

CMS engine – This forum is powered by b2evolution CMS, a complete engine for your website.