Recent Topics

FIXED: URL [https only] redirect > with database edit

Started by on Mar 12, 2019 – Contents updated: Mar 12, 2019

Mar 12, 2019 12:32    

FIXED: URL [https only] redirect > with database edit

I made changes to the URL parameters and ended up with a redirect. I changed from [http and https] to [https only]

I had thought the blog was on my new server that has https but it wasn't, and without reading all the detail, when Firefox said "Your connection is not secure" I installed a certificate. The result is now a redirect to another domain.

I have contacted the host and await their laughs. Meanwhile I wondering how to undo the mess without a database hack, and failing that a clue as to which table I need to modify would be comforting - I'm going to look anyway but I've been told off before for hacking the database so any support would be invaluable. :)

Complete URL where problem appears :http://unveiled.info/blog
Name or URL of your webhost :vooservers
Exact b2evolution version :6.10.5

Mar 12, 2019 12:57

Updates:
Checking datadbase

1) It's not under b2evo_settings, which seems like the proper place as it is under settings in the back office.
2) Can't find it searching the database as a text file
3) Maybe the change is to a file, like [basic_config] or something ?? Nope! there's been no file change there.
4) Ah! maybe an .htaccess file Nope! that hasn't changed since 2015

Mar 12, 2019 13:32

Add exception and this occurs

Mar 12, 2019 13:48

OK I have a response form the host

The reason for the "Your connection is not secure" message is due to the fact that the SSL being provided for your site has the incorrect common name and therefore Firefox and all other browsers see that as being insecure. The reason for this to happen is due to the fact that on Mercury the majority of sites are using a shared IP of 194.0.252.3 which has the aforementioned SSL certificate bound to it. Usually this would be remedied by implementing SNI however the current OpenSSL version (0.9.8e) running on Mercury does not support SNI. Unfortunately we're unable to update OpenSSL past this version due to the OS (CentOS 5.11) as this is the latest version of OpenSSL available for this version of CentOS.

In order to resolve this you would either need to disable forced HTTPS or alternatively you would need your own IP to bind the website to. If you're interested in the latter this would be an additional £1 per month for one IP.

So it's back to 'unbinding' the site from [https only] ???

Mar 12, 2019 14:17

Ok I have found the setting in [evo_coll_settings] >> [http_protocol] >> [always_https]

So I'm wondering if to just delete the row or edit it ??

Ok have edited to [http_protocol[ >> [allow_both] and

All is GOOD :)


Form is loading...

CCMS – This forum is powered by b2evolution CMS, a complete engine for your website.