Recent Topics

[1.10.x] Fatal Error after installation

Started by on Feb 29, 2008 – Contents updated: Feb 29, 2008

Feb 29, 2008 05:04    

My b2evolution Version: 2.x

Okay, so this is the first time I've used b2e, and I have to say, it looks really cool and I'm really excited to start using it... however... I can't get it to work after the installation. The installation process proceeds perfectly and finishes without any errors. After I'm done and it askes me to log in using "admin" and the randomly generated password, I get the following error.

Fatal error: Call to a member function on a non-object in /home/content/c/l/i/clintlp99/html/claudrey/blogs/inc/_main.inc.php on line 447

Then, if I try to reload the home page, it gives me the following error.

Fatal error: Call to a member function on a non-object in /home/content/c/l/i/clintlp99/html/claudrey/blogs/index.php on line 59

I'm no php expert by any means, but I'm very technical, so I'm sure if I had some idea of how to fix it, I could get around it. Do any of you have any thoughts? I've deleted my MYSQL db 3 times and tried a fresh installation all 3 times, but I still get the same error. I've even tried starting "anew" using the installation provided by b2e.

Any help would be greatly appreciated.

Feb 29, 2008 05:13

Howdy Sathed!

So you might try searching these forums for things folks have learned about that problem because it has been seen a few times already. Off the top of my head I can't recall the best answer available, but I can list a few things that I *think* are worth thinking about.

- Did you do a plain old fashioned upload of the unzipped files with something like FileZilla or any plain-jane FTP program? Someone recently had a different problem that was cured by not using SSH (whatever that is).

- Did you CHMOD folders and files thinking it was a good idea, or possibly thinking it was a bad idea but you read something that told you to? AFAIK the only things you need to CHMOD (after the installation is done) is the media/ and media/blogs/ and media/users/ folders, and even then you only need to do that if you can't upload stuff through the file manager and want to.

- Oh yeah now I remember the really good one! Your PHP and MySQL versions would be nice to know, but what really really kicks the cow is your version of Zend Optimizer. I think... Like, something about how it's got to be better than 1.3 I think? Yeah searching these forums for the keywords zend optimizer (or maybe only zend) with Afwas as the author will probably find the thing I'm thinking about.

Are you on godaddy?

Feb 29, 2008 05:17

Well, the unzip was as old fashioned as you can get I guess you could say. I usually use the decompression tool build in to XP, however, I use Flash FXP to upload.

No, I didn't CHMOD any of the folders.

Not sure on the PHP version as I'm not hosting this on my local machine, it's being hosted via GoDaddy.com and my version of MySQL is 5.0.

Feb 29, 2008 05:22

Cha CHING!

The fourth page of http://forums.b2evolution.net/viewtopic.php?t=13975 is where Yabba finally figured out what was killing shunsai's upgrade (and I suspect your installation): old Zend Optimizer on some of GoDaddy's servers.

Tell your host you want to run b2evolution v2.4.0 and learned in the forums that you need to be on a box with a current version of Zend. Hopefully that'll be enough to get them to move you. Else beat them up with the thread linked in this post.

oh and welcome to the forums. Sometimes we're slow to respond but we usually get around to trying to help out.

Feb 29, 2008 05:23

Wait a minute: LOCALLY hosted? Like: on your own PC? If that's the case you have to talk to yourself about what version of Zend you have, and get yourself to upgrade if you can ;)

Feb 29, 2008 05:31

No, I'm not hosting it myself. GoDaddy is. Thanks, I'll talk to them.

Mar 03, 2008 22:10

Okay, so I spent the weekend tearing my hair out over this and I actually came up with a pretty awesome solution to the problem.

According to every single post on the internet I could find, GoDaddy was using "outdated" or very "old" versions of Zend Optimizer. What I couldn't figure out is why a company as large and as well known for hosting as GoDaddy is would use an outdated version... They are not. What I found is that you can have multiple versions of Zend running on the same server. Why you ask, would this be important? Well... I can't answer it completely, except to say that there is compatibility issues with PHP4 and PHP5 and the different versions of ZO.

Ultimately, I figured I would take a shot in the dark, copy and paste the following (exactly as listed) into notepad, save it as php.ini, thus creating my own .ini file to upload (I didn't have one already). And just so you know, I didn't create this code. This code is provided by GoDaddy to help in the use of ZO.

[Zend]
zend_optimizer.optimization_level=15
zend_extension_manager.optimizer=/usr/local/Zend/lib/Optimiz er-2.5.7
zend_extension_manager.optimizer_ts=/usr/local/Zend/lib/Opti mizer_TS-2.5.7
zend_extension=/usr/local/Zend/lib/ZendExtensionManager.so
zend_extension_ts=/usr/local/Zend/lib/ZendExtensionManager_T S.so[/code]

If you look at this code, and believe me, you don't have to be a genius at programming to figure it out, you can see that this was clearly designed for version 2.5.7 of ZO (which does not work with 2.x of b2e). I figured what they heck, I'll change it to 3.3.3 (most updated version of ZO) and see if it works.

I changed the code, saved the .ini file, uploaded it, and lo and behold... I have my very own b2e blog! (That really works!)

For all of you out there that think GoDaddy is using outdated software, they are not. If anything, they have gone the extra mile to make sure that every version of ZO is installed and ready for use.

For any of you who would just like to copy and paste the code I used in my .ini file, here it is.

[Zend]
zend_optimizer.optimization_level=15
zend_extension_manager.optimizer=/usr/local/Zend/lib/Optimiz er-3.3.3
zend_extension_manager.optimizer_ts=/usr/local/Zend/lib/Opti mizer_TS-3.3.3
zend_extension=/usr/local/Zend/lib/ZendExtensionManager.so
zend_extension_ts=/usr/local/Zend/lib/ZendExtensionManager_T S.so[/code]

So, needless to say, it was a learning experience this weekend. And believe me, this forum post is going to be my very first blog post on my new b2e blog! hee hee!

S

Mar 03, 2008 22:51

And a very big THANKS for sharing this solution in such a detailed manner!

:cookie: :)

Mar 13, 2008 21:13

EdB wrote:

And a very big THANKS for sharing this solution in such a detailed manner!

:cookie: :)

I dont have godaddy. Any way to know what version is running? A script?

Mar 14, 2008 00:09

It worked, you jsut have to add it to the main directory and the htrv

Mar 21, 2008 21:57

Have the fatal error in html/blogs/inc/_main.inc.php on line 447. I've added the php.ini file with 3.3.3, and I'm still receiving the same error.

Yes, I'm hosting on GoDaddy :-/ - and other than having to "seed" the SQL DB with one record, my install (initial) of B2evo 2.4.1 went fine.

I read the post about Joomla - do you think it's worth a try - or copy .htaccess to the root? Or blow it off and call GoDaddy? :(

Thank You!
Lucie

Mar 21, 2008 22:38

I have requested an upgrade to PHP 5 and did a search for Zend Optimizer while I was at it...and found this:

GoDaddy: Zend Optimizer is installed on all Linux Shared Hosting accounts for PHP4. Customers can upload newer versions of Zend Optimizer (and other PHP modules) and reference the path to their files.

CAUTION: This will not work with PHP5. If you attempt to use the installed version of Zend Optimizer with PHP5, it will cause problems.

MUST I have Zend Optimizer?

Lucie :roll:

Mar 22, 2008 04:08

Sathed, I'm in the same boat as you, but much less knowledgeable on php, b2evo, etc. Can you describe the exact process that made it work for you? The php.ini file that you created...did you just upload to your base public directory of your server, or the /blogs directory, or a different directory? Did you just have to reload the blog website to get it to work?

Do I need to include the [Zend] at the beginning and [/code] at the end?

Thanks!

Mar 22, 2008 13:38

CWheel,
The code above is exact....just copy and paste it into notepad and save as php.ini. Load in in the root directory of your remote host and also in blogs/htsvr.
Those were the references I found in the forum. I specified 2.5.7 - as that is what the reference at GoDaddy indicated.

My login is still not working - but GoDaddy indicated to wait 24 hours for the move to the PHP5 server (which you can request automatically through your control panel) - and I know the move is still taking place, as my mail is not working still...
Lucie

Mar 22, 2008 14:22

thanks lucie, I'll give that a try! Can you let us know if the switch to 5.0 worked for you?

Mar 22, 2008 19:23

The upgrade to Linux 2 and PHP5 works!! :D

I logged in just fine.

I have blogs!!!

Lucie

Mar 30, 2010 00:09

I've got a b2evolution blog(version 3.3.2) hosted with GoDaddy under php5 (*edit - my bad, it's php4, MySQL 5). Got the line 477 error after I uploaded the b2e files, uploaded Sathed's fix (the php.ini file) and the 477 error went away.

I was able to log into the blog, make changes, and have used it for a few months with no problems. Now suddenly after not doing anything with it for a few weeks, when I go to log in, the line 477 error is back.

I did a trouble ticket with GoDaddy and they say nothing should have changed on the server side. The php.ini file is still there, seemingly unmodified since the date I first uploaded it.

Unfortunately, I know next to nothing about php. We did have someone create some .php pages for us, but they say they didn't add anything but the basic web pages we asked for (a home page with a link to the blog on it, a few basic info pages), no new .ini files and no changes in the b2evolution folder.

Can anyone tell me what could cause the error to return, and what I can do about it?

I found a GoDaddy help file that suggests those lines from the php.ini file as a fix for problems with the zend optimizer (the blog page works with the php.ini, I just can't log in to make changes anymore)

I guess as a last resort, is there a way to re-install the b2evolution software without losing the posts and pictures I already have?

crstimbers

Mar 30, 2010 13:00

Well, the unzip was as old fashioned as you can get I guess you could say. I usually use the decompression tool build in to XP, however, I use Flash FXP to upload.

*removed

Mar 31, 2010 03:05

Well, the php.ini file has always been in the blog folder, and seemed happy there. But I got the impression the server somehow wasn't seeing it before it tried to run the b2e login code. Copied it into the root folder (and a few other places for good measure) and suddenly I can log in again.

Apr 29, 2010 17:48

8| Ok, here is my error code in 2.4.7

Fatal error: Call to a member function on a non-object in /var/www/vhosts/tailwheelsetc.com/httpdocs/blogs/inc/_main.inc.php on line 447

I have tried the php.ini file in the rootserver and in the htsvr, heck, anywhere I thought it would be useful, and I am still gettinmg the error. I really want to use this program, but may have to use a different blog program if I can't get this to work

Line 447 in _main.inc.php is the following:
$User = & $UserCache->get_by_login($login);

Help!


Form is loading...

b2evolution CMS – This forum is powered by b2evolution CMS, a complete engine for your website.