Recent Topics

linkblog URL

Started by on Mar 07, 2008 – Contents updated: Mar 07, 2008

Mar 07, 2008 06:07    

My b2evolution Version: Not Entered

I have a linkblog. When I hover over a link, I see the link's URL in the bottom left corner of my browser window. When I click on the link I am directed to the correct URL (i.e. I can see the contents of the linked website), however, the url in the url box and the tab of the browser window is that of my blog. How can I change this to show the link's url and title?

Thank you.

Mar 07, 2008 06:36

Got link? I'd kinda like to see this happening ya know? But really it sounds more like a browser problem than a b2evo problem because if you are on a different website and your browser is still showing the address from a previously visited website your browser has a serious problem. Or so it sounds to me...

A link to your blog would be quite nice.

Mar 08, 2008 22:01

That's because you stuck your blog in a frame. The sites linked in your linkblog are loading IN your main frame, so of course the address bar shows your URL. http://localecology.org/blogs/index.php?blog=2 works as one would expect.

Frames are evil. This reminds me to restore my frame-buster...

Mar 09, 2008 00:42

How do I remove the frames? I am new to b2evo and PHP.

Thanks EdB
- ecology

Mar 14, 2008 13:30

Sorry 'bout not getting back to you sooner on this, especially since all I can really tell you is "I don't know" how to get rid of the frame thing.

Basically b2evolution didn't put it there, so somewhere you have a file that looks something like this:

<html>
<head>
<meta name="Ley fields farm" content="Ley fields farm">
<meta name="keywords" content="keyword1, keyword2">
<FRAMESET ROWS="*,0" FRAMEBORDER=0 BORDER=0 FRAMESPACING=0>
<FRAME SRC="http://localecology.org/blogs/index.php?blog=2" NORESIZE>
</FRAMESET>
</head>
</html>


THAT is the page that is embedding your page in a frame, and therefore trapping all your outbound links in what looks like your domain. It also sucks for the search engines because what I just pasted is all they know about your page.

Anyway what you've got to do is find the file in either your root directory or root/localecologist/ directory that happens to have that stuff in it, then delete it, then figure out how to get your blog to be where you want it to be.

Oh you might want to start with whatever tool you used, if any, to install b2evolution because it might have been why your installation ended up inside a frame.

Best of luck!

Apr 22, 2008 01:44

The index page at "http://localecology.org/localecologist/" loads your blog in a frame. Some people do this as an aestetic change so the URL is pretty instead of "http://localecology.org/blogs/index.php?blog=2". It also helps to somewhat obfuscate the location of your blog, which some say confuses bots, therefore less spam. It might work for a little while, but in the long run it's not worth it IMO.

You can get rid of the frame, and still have the pretty URL by simply linking to "http://localecology.org/blogs/" on you main page. All your setting are correct, so the main Blog does load, I checked.

Finally, if you really want to have your Blog at the URL "http://localecology.org/localecologist/". I'm pretty sure you can just do an installation of the same version to that directory, and it will work. Move your custom skin over and your done. Well, almost, don't forget to try the blog first,a nd then change the link on your main page.

This will help hide your blog from Bots since' it isn't the default directory name, but use the antispam, since they will eventually find it. :)

I'm kinda new to all this myself, so don't forget to back up your databases and files someplace safe before following any of my instructions.


Form is loading...

Build your own website! – This forum is powered by b2evolution CMS, a complete engine for your website.