Recent Topics

1 May 12, 2008 05:34    

My b2evolution Version: 2.4.2

Fresh install- downloaded 2.4.2 today.

Can login as Admin with random generated password from install, but when clicking on any control panel link I am prompted to login again.

Please note: I've already looked over the FAQ about the "baseurl" in the _basic_config.php file and am allowing cookies AND have cleared my browser cache & cookies AND there is no security software blocking it AND have restarted the server even.

Windows 2003 IIS 6.0
PHP 5.2.6

Help please? :'(

5-12-2008 14:00
Can anyone help me?

2 Oct 02, 2008 01:27

Still having the same problem with v2.4.5

Can someone help?

It's been about 5 months and still no answer to my post.

3 Oct 02, 2008 02:54

did you try

$instance_name = 'b2evo'; // MUST BE A SINGLE WORD! NO SPACES!!

changing 'b2evo' to sth unique in your conf/advanced.php ?
might help

4 Oct 02, 2008 04:14

Yeah! Thank you for responding to my post. I will elaborate some more...
I have changed the "instance_name" in the advanced.php file, I have no security software whatsoever running on this workstation or any other software that would block cookies, I have tried both IE7 and Firefox3.0.3, I have tried it remotely (from another office computer), I can see the cookie in my browser and it looks fine, I am using it on a subdomain (, I've tried numerous fresh installs... to be clear, I can login as Admin and see the Dashboard but when I click on any other menu item I am prompted to login again and I cannot view anything else but the Dashboard. I have turned on Debugging but I am not sure what to look for. I can't think of anything else right now.

5 Oct 02, 2008 04:19

sounds like a particular issue in your case.. would you mind providing a link to your blog, if only registrations are enabled ofcourse .. or provide a test user id and pw with zero permissions, just to see if we also would encounter any problem

6 Oct 02, 2008 04:26

Of course!

I can't create or change the logins, if I try the login page comes up. All I can give you is the Admin and temporary password that is generated after install. Should I post the admin login here?

7 Oct 02, 2008 05:29

shouldnt hurt as it's a newly blog, and u dont have much to lose i believe, however it may not be the best idea, but you can pm a moderator willing to help, apart from all i would personally might be able help ya out with it if you pm me the admin id and pw (as it's a new install i'd accept taking the risk) and an ftp access (with only the access to teh /blog root)

8 Oct 02, 2008 08:43

i was about to leave, just had a quick look before i did and noticed that you can login smoothly from

is that right ?

because i have tried logging in from the default login link (i assume you were doing so), which is,

had problems logging in from this one

so , looks like a redirecting issue relevant to using subdomain.. couldnt look into it much, lets hope someone else can come up with answers with these clues, before i get back, in the meantime, you can try giving the details to the pro guys(mods-administors) if they have the time

see you later

9 Oct 02, 2008 08:45

how do i know who to give the info to?

i wasn't logging in from a link, i just typed /admin.php (same as link after set up to login for the first time as admin).

thanks! you're right, it works from your link. very strange. and after it works one time from somewhere, it seems to work normally... so far anyway.

10 Oct 02, 2008 08:55

seph wrote:

how do i know who to give the info to?

i wasn't logging in from a link, i just typed /admin.php (same as link after set up to login for the first time as admin).

thanks! you're right, it works from your link. very strange. and after it works one time from somewhere, it seems to work normally... so far anyway.

yea consider it as a temporary solution P: i'll look further into that i promise, but i am not that capable, ll take my chances though..

have you done any redirecting (temp/perm) through your host panel ? i assume you havent done one through your .htacces as you dont even have one! (:you might want to rename the sample.htaccess to '.htaccess' sometime.. and have you changed anything in your files ?

unless you dont know, mods are not cold hearted administors in here.. i'm pretty sure if any of them has the time to look into it they'll post here..

main reason to it really looked using a subdomain to me.. and i havent used b2 in a subdomain earlier, maybe sth who did may give some tips.. a fresh install may be the solution as well despite the fact that nothing seems wrong with your server at the first look

11 Oct 02, 2008 09:08

I really don't know in what context to use redirects for this. I mean, I know what a redirect is, but I don't know how they are useful or what they are used for with blogs. I just figured people would put in the domain or URL and just navigate through links or menus. Can someone tell me how I should utilize the .htaccess file? I thought it was just for Linux installs. Also, this is a fresh install with no modifications- straight out of the can.

12 Oct 02, 2008 09:34

Try this :

Crack open inc/_core/_template.funcs.php and change this section of code ( approx 80 -> 90 ) to look like this instead :

	/* fp>why do we need this?
	   dh>because Location: redirects are supposed to be absolute.
	if( substr($redirect_to, 0, 1) == '/' )
	{ // relative URL, prepend current host:
		global $ReqHost;

		$redirect_to = $ReqHost.$redirect_to;

	if( strpos($redirect_to, $htsrv_url_sensitive) === 0 /* we're going somewhere on $htsrv_url_sensitive */


13 Oct 03, 2008 07:39

I had to restart IIS (to install gd2 extension) and now the login issue is back. I tried the edit for _template.funcs.php and that didn't work. WEIRD. The thing is, it worked once an experienced b2evol admin logged in from a specific URL. Then the issues went away and I was able to login and stay logged in from URL's I couldn't before- once it started working for a user. I think this is some kind of issue with PHP/IIS and how it's handling reference links, cookies or URL's in combination with eachother. I don't think this is a browser side issue but a server side issue, in that there is some code somewhere in this package that isn't playing well with a non-Linux server set up. I tried again to login from the URL that tilqicom logged successfully from but the issue still persists for some reason. I wish I could go Linux but I can't right now. Any ideas?

14 Oct 03, 2008 08:04

Breakthrough! I don't know what it means but here is what worked for me... I logged in and a cookie was created in my browser.
I then changed: $instance_name = 'b2evo'; to something else. But, I then did NOT clear my cookies and logged in again. Now my cookie has 2 entries in it with different instance names and I am able to stay logged in!!! I don't know why this works.

15 Oct 03, 2008 08:10

Yep! It's consistent. I cleared my cookies, logged in and could not stay logged in. I then changed the instance name, did NOT clear cookies and logged in again and was able to stay logged in when my cookie has 2 instance name entries in it!!! I don't want to have to do this for all blog users so they can stay logged in. Maybe this can be fixed?

16 Oct 03, 2008 18:04

glad it's solved after all..
many users dont even know they should change that 'instance_name' to sth unique..

i wonder why b2evo doesnt assign a unique name upon install ? idk, maybe a random generated word like '2kkxlmn' just to bu unique to be changed later?

and oh btw, remember.. posting within 5 months isn't considered a double post (: try your chance in a shorter period next time, it might ve been missed

17 Oct 04, 2008 01:35

This is only a work around or temporary fix. But I would have to have every person who wants to login, login once then notify me, then I would change the instance name and then they would have to login again. I really don't want to have to do this for a hundred users, each one at a time. Maybe an admin could see what these symptoms look like and there could be a fix for the code so that this can be avoided? Normally, this would be considered a bug.

18 Oct 09, 2008 17:01

I think this issue is somehow tied to this file... /inc/sessions/model/_session.class.php
I don't know why I have to have 2 saved cookies with different instance names to make this work. I can't go on changing the instance name for each user that needs to login properly. Help?

Another separate point that may be related... I also noticed that cookies do not expire when you expect them to when set in /conf/_advanced.php

I'm not saying that the expiration is the issue with my problem but I think they are related somehow.

Cookie expires at 10 years as per the setting in the _session.class.php file.

This post mentions the cookie expiration:

19 Oct 09, 2008 21:19

Please enable debugging ($debug = 1 in /conf/_advanced.php IIRC) and see what it says in the "session" section.

It should look similar to this:

Session ID received from cookie: 2
Session ID is valid.
Session user_ID: '1'
No session data available.
Session data saved! 

20 Oct 09, 2008 23:22

debug output:

Session ID received from cookie: 1871
Session ID is valid.
Session user_ID: NULL
Session data loaded.
Session data[core.pwd_salt] deleted!
Session data[Debuglogs] updated. Expire in: 60s.

21 Oct 12, 2008 18:52

That looks ok.
You only have a single blog on, correct?
Somehow this sounds like you may have some b2evo cookie for only, too (or other subdomains). If you have several (sub)domains (and want to hold the cookie on all of them), you should adjust $cookie_domain manually.
I cannot see why you would need to have a cookie for two instance names, to make it work.
Make sure you delete all related cookie (""), when debugging this further.

It might help, if you could post a URL for your installation, so I could take a look myself (you can send it to me by PM).

@tilqicom: it does not sound like the problem is a non-unique instance name, but that he needs two cookies with two different instance names to make it work.

23 Nov 05, 2008 18:21

For the record, seph and me debugged this per PM and it turned out that with his setup, $_COOKIE is messed up (e.g. in phpinfo()), when there are any GET params (even only a "?" IIRC). gets the cookie(s), but not.

There's obviously something f*cked up in the PHP setup, maybe caused by IIS or the way it's setup. Or with a particular PHP version and IIS.

(In the first case, _COOKIE["cookieb2evo2session"] is set, but in the second case, it's quite obfuscated into _COOKIE["?rstval"].)

Nothing we can do in b2evo to fix it.

I'm not sure, if the post mentioned by Afwas is the same though (just skimmed it). Why would anybody use IIS anyway? ;)

Form is loading...