Recent Topics

1 Mar 11, 2010 23:36    

My b2evolution Version: 3.3.3

Hi All,
Just upgraded to version 3.3.3 yeasterday, all was well.
Today I have a hard time to login, I have to enter user and password a number of times (all corectly) before I get in the backoffice... annoying to say the least.
secondly when I went to create a post, tinymce could not load, the error said wrong url or some such.. tried it on all my pc' same result. so went into the plugin settings to see if anything looked wrong there, saw nothing ontoward so did a reset all to default. this did not matter one bit same problem was still there. So I downloaded the latest version, removed the plugin in the back office, uploaded the new one. now when I click on either update plugins or install a new plugin it geves a 404 page saying the link is broken. the page it attemps to open on new plugin is [ http://admin.php/?blog=5&ctrl=plugins&action=reload_plugins ] which to me looks od in that it is missing the domain address.
Any ideas onhow to fix this, I need tinymce working right now posting is a pain in the ...

the url is indeed wrong I had to manually enter the domain in the address bar before the //admin.php etc etc
now did that got tinymce installed but it is still not working the error it gives is this:
Compressed TinyMCEW javascript could not be loaded. Check the "URL to TinyMCE" plugin setting

HELP help help really need to get this working again....

Ok got a little further but no closer than before really, I used fiddler to trace the calls made, and when it is calling for tinymce is calls http://plugins/tinymce_plugin/tiny_mce/tiny_mce.js?v=3.3.0 and after http:// there is no and this is same problem above with the install new plugin I am getting.... so where to I add in the domain name, since this is what both miss?!?!

no reply yet hmm no solution??? somebody???

2 Mar 12, 2010 03:03

ok the solution was in the _basic_config.php in the conf directory, I had to remove the multiline comment and make active the following statement

if( isset($_SERVER['HTTP_HOST']) )
{ // This only works if HOSt provided by webserver (i-e DOES NOT WORK IN PHP CLI MODE)
$baseurl = ( (isset($_SERVER['HTTPS']) && ( $_SERVER['HTTPS'] != 'off' ) ) ?'https://':'http://')

this statement is surrounded by /* and */ so not active, remove the */ and /*
now it all works fine again...

God Bless

Form is loading...