Recent Topics

1 Jun 19, 2006 06:46    

I changed my _main.php file so a few existing links would work, and now my blog will not open at all....Help!


2 Jun 19, 2006 07:39

Which _main.php did you change? The one in skins/yourskin folder (for all installations), or the one in b2evocore (for pre-1.6 installations) or evocore (for 1.6 installations) or ???????? (for CVS version installations) folder?

Undo the changes bit by bit until you find which portion is killing your blog OR show us the parts you changed so we can try to help. Only the parts you changed please! Most of us know what the _main.php file looks like ;)

Oh and the version of b2evolution you're running will help.

3 Jun 19, 2006 07:48

I changed the _main.php in skins->custom

I have tried to undo the changes...all I was trying to do was change links from:
generatorfacts com/page.htm
because the copied relative links did not work in the /blog/ folder

I made the page writable and tried to change them. I also deleted a link from the bottom...these don't seem like things that should cause a problem right ?


4 Jun 19, 2006 07:51

I believe that the version is : b2evolution 0.9.1

5 Jun 19, 2006 07:53

A couple of thoughts for you. .htm files don't mean anything in b2evolution because all files, unless you do a static shot of your blog's main page, are .php pages. Second, relative links never work in b2evolution. b2evolution uses the "base URL" tag in the head to point to skin-specific stuff, which helps b2evolution but messes up someone trying to take advantage of relative links. With regard to this second issue, try using full URLs for any links to your own pages that you want included in your skins/yourskin/_main.php file. Though they may be a bit more to initially create, they are as valid as the 'shortcut' versions and, more importantly, will work within your b2evolution blog.

Hope it helps!

6 Jun 19, 2006 08:00

Right, that is all I was doing, but now I can no longer access my blog. When I click on a link to it, it pulls up errors:

Warning: main(/home/generato/public_html/generator-facts-blog/b2evocore/_main.php): failed to open stream: Permission denied in /home/generato/public_html/generator-facts-blog/index.php on line 20

Fatal error: main(): Failed opening required '/home/generato/public_html/generator-facts-blog/b2evocore/_main.php' (include_path='.:/usr/local/lib/php') in /home/generato/public_html/generator-facts-blog/index.php on line 20

Any ideas there ?

7 Jun 19, 2006 08:31

Line 20 reads:

require_once dirname(__FILE__).'/b2evocore/_main.php';

8 Jun 19, 2006 08:36

I have it idea what is going on.... :)

Form is loading...