Recent Topics

1 Jan 20, 2019 03:39    

Trying to upgrade from an OLD version of b2e from around 2007. I have not been able to get the software to respond since moving all my content from an old server to a new server. The domain has not changed or the location of the files within the directory structure.

Site address
https://sfriday.com/blog

Directory structure
/home/sfriday/public_html/blog

I uploaded the files and started the upgrade process, but I get an error right away.

2 Jan 20, 2019 04:11

So I deleted the database, then restored it from the backup I had from before the upgrade, and then I tried again but with different baseurl info in the _basic_config.php file,

$baseurl = 'https://www.friday.com/blog/';

3 Jan 20, 2019 10:40

Did you Continue Installation ?
And watch out for http | https option (see screenshot)
Did you check the .htaccess for an http directive?

4 Jan 20, 2019 22:23

When I did try to continue, I got an error about the skins table.

Here is the .htaccess that is in my /public_html directory.

RewriteEngine On

RewriteCond %{HTTPS} off
RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

# BEGIN cPanel-generated php ini directives, do not edit
# Manual editing of this file may result in unexpected behavior.
# To make changes to this file, use the cPanel MultiPHP INI Editor (Home >> Software >> MultiPHP INI Editor)
# For more information, read our documentation (https://go.cpanel.net/EA4ModifyINI)
<IfModule php7_module>
   php_flag display_errors Off
   php_value max_execution_time 7200
   php_value max_input_time 60
   php_value max_input_vars 1000
   php_value memory_limit 64M
   php_value post_max_size 8M
   php_value session.gc_maxlifetime 1440
   php_value session.save_path "/var/cpanel/php/sessions/ea-php72"
   php_value upload_max_filesize 10M
   php_flag zlib.output_compression Off
</IfModule>
# END cPanel-generated php ini directives, do not edit

There is no .htaccess file in the /public_html/blog directory where I have the software installed.

So I reset the database from the backup and tried again,

5 Jan 20, 2019 23:10

I'm not that familiar with .htaccess and not sure it's relevant
b2evo uploads it's own .htaccess in its root folder which you can read.

But the issue seems to be a problem with the skin recognition.

The database is very old and the updates should be automatically incremented DB v.9407 to DB v13070 will be a bit slow maybe, so you could just try again and see if it gets past the skin issue.

The problem with a field not existing in database implies a jump in updating with parameters that are not available.
I think you'll have to wait for one of the developers like @fplanque to shed some light on this :(

By the way is this an ftp upload or an automatic upgrade.?
Have you checked other posts https://forums.b2evolution.net/upgrade-from-a-very-old-version-2-4


Form is loading...

Free CMS – This forum is powered by b2evolution CMS, a complete engine for your website.