Recent Topics

1 May 08, 2018 17:14    

Hello all

I tried to upgrade today from 6.8.8. I thought I would try the automated method. It was looking good but when I went to my site I got the database number error. If I click on the install link I get a 503 error.

Neither can I get into my files using ftp. It just goes on an endless loop of timeouts.

Do I need to do a fresh install? I've got database backups.

Here's the site that's down

Any suggestions gratefully received.


2 May 08, 2018 17:21

I think the auto method isn't recommended unless you have at least 5.0.6 looks like you were on 3.3.3 ??


This feature is considered future proof only starting at version 5.0.6 (it means you should have 5.0.6 installed before attempting to upgrade with this feature).

So yes, best do a new install.

3 May 08, 2018 19:03

Thanks @amoun. . It was 6.8.8 but yes ok, fresh install.


4 May 08, 2018 20:52

Sorry about the 6.8.8 but your site said 3.3.3 ??

As it was a newish version I should say I've had loads of problem. It seems it may be my server that times out when doing automatic updates so I now ftp over a whole new set of files each time. I'm currently using 6.9.7 on my main site

5 May 09, 2018 10:21

That's strange. In back office ... When I could access it ... It reported 6.8.8.

Your mention of ftp makes me wonder how I am going to upload a new install, given that my ftp doesn't work any more since the decision (I am now regretting!) to upgrade.


6 May 09, 2018 10:37

I'm wondering why your ftp isn't working as I don't see the connection between b2evo and overall access to your hosted space.
What do you use to ftp?

7 May 09, 2018 10:53

Is this the page you get via the install folder, as it looks like the wrong installer (3.3.3) instead of (6.9.7) which I'm assuming the upgrade was meant to be. So I am wondering why you can't gat access via ftp and get rid of the install folder and try a new version of that.

8 May 09, 2018 11:59

Hello amoun

This is odd -- that page has changed since yesterday. Yes, that is what I see now.

I can't connect to ftp at all in order to get rid of the install folder. I've tried two different operating systems now, and I just get endless timeouts.


9 May 09, 2018 13:06

When you say you used two different operating systems, that implies Windows, Apple, Ubuntu etc. What FTP programme did you use, Filezilla would be my preference.

I wonder how you installed the first b2evo.

If you mean you did use an FTP programme rather than 'operating system' I am a bit concerned that either your host is playing up, yet at least there is the install page, otherwise the password may have become corrupt or compromised.

If it is urgent I can message you my land line to chat. I'm in Cornwall near Plymouth

Could use the phone but the downside is that all the resolutions should go thought the forum for the benefit of other users who may have a similar problem. So after a call the details should still then be posted, and a lot can be said over the phone. :)

10 May 09, 2018 13:42

Hiya amoun, that's a very kind offer.

I installed b2evo many years ago manually from the b2e site, not through the Softalicious or whatever it's called.

By OS, I mean I have always used gFTP in Linux Mint (now locally on 18.2), but then when that didn't work I switched to an installation of Bodhi Linux that I have on a different partition which sometimes gets me out of problems like this. Unfortunately the problem occurs on both. Perhaps the password is compromised, as you say.

I have put a request into my host and see what they say and I'll update this as soon as I can.

Thank you again


11 May 09, 2018 13:55

I don't know gFTP and I hope it's not a browser base ftp, which may be a problem. Would you not like to try Filezilla which being a stand alone app should connect to your site if the password is ok??

I also noted that your link goes to an https site whilst the root directory is http. Maybe the host has update the host to https and that is a problem ???

Keep us updated please. All the best

12 May 09, 2018 14:16

gFTP is a stand alone app which was just in the Mint repositories. I'll try Filezilla, although if all this is a problem with gFTP I'd be surprised. I'll ask my host about that http/https discrepancy. I'll keep you updated -- only got ten mins left on this library computer but will update when I can.

My personal feeling is that it's a weather related-issue. We're not used to having actual sun and no rain for a 72-hour period up here in Lancashire and it's sending the computers of Lancashire doo-lal.


13 May 09, 2018 15:33

OK Lancaster isn't on my walk by route so hope all goes well :)

14 May 17, 2018 18:49

Good afternoon everyone, from an uncommonly warm Lancashire. I will miss out a long story, but I was so frustrated with this that I reinstalled my OS, which threw up what I think was the core of the problem -- outdated versions of php and mySQL

I have now managed to install the latest version to a directory, .../public_html/x.

Can I tax your already weary patience by asking how I can import my mySQL database with ten+ years' worth of my dreary drivel, into the new site?


Edit: hang on, having had a look at the manual, it gives this very sensible advice: "If you are not a technical person, ask your web host to do it for you. This is the easiest way." :)

15 May 18, 2018 03:53

Presumably you have a new, but empty database= in your new install. Hopefully your host provider will do as you ask, else if you have a good control panel with your host you may find an application called phpMyAdmin, wherein your can import any data to a pre-existing database or make a new one.

16 May 18, 2018 19:33

Thanks amoun. Yes, it's as you said, I've got a new empty database. I've also got a cpanel with phpMyAdmin in it. That presents a scary-looking menu more complicated than the food menu at Wetherspoons, so I've asked my host to help me out importing the old database. I'll keep you in touch with the thrilling developments in this white-knuckle database drama.


17 May 18, 2018 20:15

Right, well, dashed hopes again.

My host's tech support imported my old database into the new one. He told me to change the public_html/conf/_basic_config.php to the new database name, user name and password. Which I did. I rebooted the computer. All I get now is the standard index.php with the sample entries. I was hoping all my old posts would be there somewhere.

FFS, this is the last time I ever attempt upgrading b2e.

Is there anything else I need to do to get my site back?

A very frustrated Helen

18 May 18, 2018 21:14

Ive just spent another two hours of my life with the very helpful staff at my host, without any results, and I am absolutely fed up to the back teeth with all this. I'm closing my site on b2e --- or rather, it's closed for me -- and I just hope to hell that at some point I can download my db of ten years' worth of utter drivel to inflict it upon someone else, but using a different platform. I am out of time and effort.

Thank you for your help amoun, and bye bye b2e. This is way too difficult for me.

I need a drink right now.


19 May 18, 2018 22:15

Well a drink seems good, pity you're so far away as I fancy one too but not alone :)

Do you have anything sensitive on your database else you could send it to me and I could try and run a site from it. If that works I can run you through phpMyAdmin.

20 May 19, 2018 09:22

Sounds like either the database didn't have the data or the host screwed up. You can check the database, which is likely to be a ****.sql file. It will open in a text editor. It may take a while, first see how big it is, I regularly delete my sessions data etc to ensure a smaller file, especially for uploading when needed. My files are only a few MBytes after years, so just looking at the size should indicate there is actually a lot of data, so it may be still available.

So once you've recovered get back here and I'll try and get to the bottom of this with you.

21 May 19, 2018 13:11

First of all, apologies for my intemperate use of the vernacular intensifier last night. We're a bit rough round the edges up here but I understand that not everyone will appreciate our Northern charm. Alcohol may also have been involved. As a gifted artist once said, "Don't blame it on the sunshine, don't blame it on the boogie, don't blame it on the good times, blame it on Prosecco."

Anyway amoun, I am most grateful to you for your kind offer. The DB I am trying to import is 137MB and it contains material which, in the mangled non-English of America, would come with a "parental advisory" so I'm reluctant to share it too widely.

I'm going to do the absolute basics first, checking the password and the database name, ('localhost' is correct, don't have to worry about that). I'm also going to have a look at my .htaccess because around about the time of the Cuban Missile Crisis I set up a redirect when I last tried to upgrade and I had to leave an orphan site to die of thirst in the wilderness of cyberspace.

However, should these measures not prove efficacious, I may pester you again amoun. Soberly.


22 May 19, 2018 18:57

Good luck!
If your site is empty it would seem that it has connected to a database just not the right one.

In phpMyAdmin, once you've selected your database (b2evo***) you shoulkd see all the tables on the left.
At the top you will see Export, try that and you will save to your computer. You can check the size to confirm it is just the demo one.
You will also see and Import option, try that, you may have a problem with the database size, which on my cPanel is 50MBytes. The host maybe able to change that.

Couldn't add images after initial post so images of cPanel on next post.

24 May 21, 2018 14:52

In the words of the song "how long...has this been going on".

Again, many thanks amoun. My php upload file limit was a convenient 256KB. I followed your instructions but the export option presented me with the eternally rotating blue circle of death. I pinged the BBC and loaded farce book, and everything was working fine, so maybe it was something to do with not being able to access the server. I don't know.

I had a new look at my site before I started this, and it displays this:

Do you think, amoun, or anyone, whether I could install a different blog application and import my DB into the new application? Or would I have these same endless problems with database numbers and all the rest of the shite that I am wading through at the moment?

I don't want to sound precious, but I've got over a decade's worth of posts and comments somewhere there, and I just want them to appear. God, how I rue the day I ever tried to update this thing!

(Oh look, the Prosecco is 14.99)

25 May 22, 2018 13:30

Hi You can add an image to the post; it's a bit odd seeing that url, is it a cloud host you use for images?

So presumably you couldn't continue from there, but it looks like it did import the database, with one error.
If you use phpMyAdmin you should be able to see if the table exists or not. Usually the name is (your_database_name.evosettings) if all the other tables are (***_.evos0_*) then ok.

By the way note the [evo_sessions] table. If you don't want the data Empty it to save space and Export/Import transfer bytes. Same with[evo_item__versions] table Empty it.

So does the table exist and is the prefix the same as the others. if it exists then the error report is wrong. Then at least click on the table in the left pane and export the table. You can read the table and check it's ok ~ i can send a copy of mine for comparison.
If it doesn't exist that odd as it would be there by default on any new install add you said it was working with the default demo content.

If the error is true then the table must be missing, which I doubt, but without checking it's difficult to know.

Apologies for all head banging

26 May 22, 2018 17:52

Ah yes, you add images, I see now (you can see a girl who can't see a massive "Add file" button might struggle a bit with myphpadmin). The image hosting site I use sometimes deletes all your images after a set amount of time.

Anyway, here's my table of tables. There seems to be a problem with the file name. All my tables start evo_*
The error message reports that it's looking for something that begins evos0. That's not right is it?

amoun, were you suggesting you could send over your *evo_settings" table? would I be able to add my own information to that and upload it? Would that work do you think?

Many thanks again -- your patience with short-tempered novices is admirable

27 May 23, 2018 10:59

Hi Looks like you are OK with the phpMyAdmin screens, and it looks like you have the [evo_settings] table as i expected, given you had the site with demo data - so no point in sending a file with the [evo_settings] table.
It seems the error message was wrong in suggesting there should be a table prefixed [evos0] so it's difficult to know what the problem is. Could just have been a glitch.

I note that does show the default [index.html] but gives a 404 error.
I've had this problem many times when the folder does exist, which I have never go to the bottom of. I may post links to topics about that, but not useful at the moment. (about .htaccess, changing permissions and resending the install folder by ftp)

So you could do two things.

First: Using ftp could you check to see if there is a folder/directory [install] in the root with the files in as in the image below. Ignore the [test] folder in it as I put it there trying to sort out why the [install] folder existed when I couldn't access in online.

The second thing is check the [config] folder for a file like [_maintenance.html] ensure there is no other file with a similar name like [u_maintenance.html] if so delete any with a letter prefixing the underscore. It just ensure there's no maintenance mode interfering with access.

There is another option and that is to hack the database and change its version manually, which I have been told not to do but have done so with success - still later with that if nought else produces any forward thinking

28 May 25, 2018 22:48

Hiya amoun and everyone

Apologies for the delay -- the dreaded four letter word intervened again.

There is an install folder, containing all the files (except your test folder) at root.

Maintenance mode in the config file is set to 0, and I can't see any other files anywhere else that might indicate I'm in maintenance mode.

Do you think we should try your suggestion at the end of hacking the DB?


29 May 26, 2018 11:50

Don't worry about the response time, this is not life threatening and should be, if not fun, then something that fits into the more enjoyable activities that each of us indulges in.

OK so we've established
a) the error is wrong in that it demands a table, prefixed wronging, that otherwise does exist
b) the install folder exists although a call via URL claims it doesn't.

First I'll direct you to other posts on a similar if not identical issue. The problem being there has been no clear solution and I still have problems with the auto update. Now I just ftp a whole new version. The issue proposed by @fplanque is there is a host issue.

I have variously checked permissions, htaccess and resent the install folder, only sometimes with success.
Changing the database version manually is not recommended and won't necessarily solve the problem as there seems to be a problem with accessing the install folder.

Query! Can you still get a message that the database needs updating.

OK I'll find the links and EDIT this post.

The following are all my posts, there are others!!

As you can see it has been a problem for me, hence my extra interest in your issue. You may want to start from the last post??

On hacking the database please see

Hope you enjoy the weekend. :)

31 May 27, 2018 15:49

This is post one of two. Post one -- this one -- deals with the wreckage of the attempted upgrade at my site's root.

In the second one, I can share a bit of a glimmer at the end of the tunnel.



Oh dear oh dear, I've just gone through links you posted. You have more patience than me amoun.

Yes, I still get the error message that the DB version is at some low number and it needs to be some higher number. Here are the screenshots.

First once should show that there is an install folder at root.
Second one should show what you see if you go to the site I'm supposed to be running.
Third one should show you what happens if I click on either of the install links.

POST TWO -- will have to wait. Bed beckons (shift work). It will be there soon. Basically the site appears but I can't log in. More tomorrow.

32 May 28, 2018 10:07

The first error page, the database message is a problem as somehow it thinks you have version 3.3.3 and wants the associated database version to reflect that, whereas the database version mentioned : 123654 : is the correct one for b2evo V6.9.7, so no need to change that. But will try and find out why it thinks you are using 3.3.3

The second problem when clicking on the install links, seems to have changed from before. I can now at least find the folder when I go to and the index.php file does try and do it's thing.

The error refers to the file /inc/_core/model/_messages.class.php not being available so at least that's easy to check for.

If it does exist then the call for it in the other file mentioned,/inc/_core/ _class_loader.funcs.php has to be the issue.

 * Autoload the required .class.php file when a class is accessed but not defined yet.
 * This gets hooked into spl_autoload_register (preferred) or called through __autoload.
 * Requires PHP5.
function evocms_autoload_class( $classname )
	global $map_class_path;

	$classname = strtolower($classname);
	if( isset($map_class_path[$classname]) )
		require_once $map_class_path[$classname];

If you have the files you could compare the code in the second one, as above, to rule out file errors.

I'm not aware of your abilities and resources, but if you have all the files on your local computer as well as the host you can check to see they are all present on both and look at the con tents using notepad or preferably

Feel like I'm saying so much that isn't very helpful :(

33 May 28, 2018 13:27

amoun -- final if you read your sentence again correctly, you will find that the bracket should be the other way round.

Right -- /inc/_core/model/_messages.class.php
doesn't exist.

Let's try uploading it from the b2e unzipped package on my hard drive... and we'll see what happens. The version on my HD is, on those lines the same as your example above. we get this, and looking at that line where the error is supposed to be gives this:

34 May 28, 2018 13:51

Going back to post #17 you say you had a basic site with sample info, so it was working

Sadly it may be a good idea to get back to that and confirm the site at least works. Then save the empty database.

If that does go well then it would seem just to be a database issue.

If that works then export/save the database with the sample info so it can be replaced at least to get the basic site working.

So can you get back to a working site with sample data?

I was looking at the screen-shit of the ftp page and note that the /inc/ folder is dated 2009.
Although when an update is made by ftp'ing files it isn't going to change the date of a folder/directory it also won't delete other files in there, so there may be conflicts after 9 years.

If you do have to ftp a whole new engine; you may be better off deleting all files and folders, except those in the /media/ folder, as long as you have the basic config details of database and password etc.

Use the same basic directory names you used the first time as maybe the 'old' database refers to folders that don't exist hence the problem with not finding files.

Of course you could always try installing 6.8.8 again and see if that works

35 May 28, 2018 22:45


I am immensely grateful for your tireless efforts on my behalf, a complete stranger. I really would like to run down to Calstock now with a bottle of what you fancy.

But I've had enough, this is too difficult. I've installed nucleus and at some point, I will start the task of importing my DB with twelve years' worth of all my rubbish into it. All the hours and hours and hours I spent on my b2e site. It's like giving away a baby. God knows what Fran├žois must feel like sometimes.

Thank you so much amoun -- you are a generous and patient man, possessing those qualities far in excess of what I can muster myself. If you ever get lost on that confusing roundabout outside Bristol and end up in Lancashire by mistake, please get in touch and the drinks are on me. 658e9bf3 squirly thing opayq dot com

(Don't be put off -- that address does work).

As we say in Lancaster
s'yu lehht uh


36 May 29, 2018 12:26

Have fun with the new site, and yes! I feel for Fran├žois. It's he that should get a bottle, nay a barrel of wine, not that France is in short supply.

37 May 31, 2018 21:39

Thank you amoun -- I really do appreciate all your help. More, really, your generosity.

Nucleus is shite compared to b2e. I'll get this damned thing back on b2e one day.

All the best


Form is loading...