Recent Topics

1 May 03, 2020 15:51    

Please see the attached print out of the upgrade. I have been using B2E for many years!

I received this error:

Notice: A non well formed numeric value encountered in /hermes/walnacweb04/walnacweb04am/b2542/pow.paulleslie/htdocs/b2e_2018/inc/_ext/pclzip/pclzip.lib.php on line 1846

Can you assist?

2 May 03, 2020 16:37

Hello again,

I made it to the installer: http://blog.lesduke.com/admin.php

Now I get this error:

Database schema is not up to date!
The b2evolution files are present on your server, but it seems the database is not yet set up as expected.

For more information, please visit our Getting Stated / Installation Guide.

This is b2evolution version 7.1.5-stable.

You cannot use the application before you finish configuration and installation.

Database schema is not up to date!

You have schema version «12910», but we would need «16010».

Please use the installer to finish your configuration/installation now.

On most installations, the installer should be here (but I can't be sure since I have no config info available! :P)

3 May 03, 2020 16:45

@pleslie wrote

On most installations, the installer should be here (but I can't be sure since I have no config info available! :P)

That's how it should work, you should be able to click on the link 'here' and continue.

You may have done that by now as I see a different problem on your site.
For example:

  1. https://blog.lesduke.com/install/test/index.html works fine but
  2. https://blog.lesduke.com/install/phpinfo.php doesn't. There is a server error 500
    This could be either a permission problem so there is no access or a mod-security issue on your server setup. On this option you could ask your host to check any mod-security issue, or if you have acces to cpanel disable mod-security to see if it will work.

4 May 03, 2020 17:01

Yes, when I try that, I get an internal server error.

It says:

"Database schema is not up to date!

You have schema version «12910», but we would need «16010»."

5 May 03, 2020 17:01

Sorry updated my earlier post before I saw your reply.

6 May 03, 2020 17:16

@pleslie wrote earlier:

Yes, when I try that, I get an internal server error.


It says:


"Database schema is not up to date!


You have schema version «12910», but we would need «16010»."

Not quite with you there??

The bit about the schema version is not an error.

The internal server issue is an error.
It is not clear
a) what you are seeing, as you didn't provide a screen shot, including url and
b) the order in which you are clicking and the messages you are seeing.

For example: this page https://blog.lesduke.com/ gives a 503 which is a b2evo issue and the install does not seem to have been completed. You can read about the umaintenance file by searching this blog for info on that.

The server error is 500, which I have already referred to, an access issue.

There are many occasions that I find the autopgrade gives me this headache, so I now manually ftp the new files and never have the problem. Yoiu can search for similar upgrade problems on this blog to get a more thorough view.

Off to work outside now, will check on you later.

7 May 03, 2020 17:35

Hi - Sorry about that. I am now checking with the web host.

I can get to this page: http://blog.lesduke.com/admin.php.

The host is telling me they cannot see any files in the install folder

But, I can open the install/index.html as you indicated.

From: http://blog.lesduke.com/admin.php

When I click on install, I now get:Forbidden
You don't have permission to access /install/index.php on this server.
Server unable to read htaccess file, denying access to be safe.

8 May 03, 2020 17:56

Hmmm - I reloaded the install folder using FTP. Now I just get a 503 error.

9 May 03, 2020 22:15

Yeap I have done the same ftp the install, even though I can see files in it. There's awhole post of mine about the same issue.

You can check the /config/_maintenace.html if you click on it you will see the error you get, I imagine as you didn't post a screen shot lol.

Anyway if there is a similar file: /config/u_maintenace.html etc delete it from the server. There should only be the one file with the text [_maintenace] with an underscore at the begining.

11 May 04, 2020 13:45

@amoun wrote earlier:

Yeap I have done the same ftp the install, even though I can see files in it. There's awhole post of mine about the same issue.


You can check the /config/_maintenace.html if you click on it you will see the error you get, I imagine as you didn't post a screen shot lol.


Anyway if there is a similar file: /config/u_maintenace.html etc delete it from the server. There should only be the one file with the text [_maintenace] with an underscore at the begining.

Hello - Well, I did just this - I deleted a file called umaintenance.html, and then refreshed. I got the upgrade page again. I then just clicked through and there it is!

7.1.5 Stable!

Thank you so much for taking the time to share this solution.

12 May 04, 2020 15:08

Glad it worked, it has been a pain for me for years :( so I only upgrade manualy just in case. I think @fplanque has indicated it's a server issue but I haven't had the inclination to discover and resolve it.


Form is loading...

b2evolution CMS – This forum is powered by b2evolution CMS, a complete engine for your website.