Recent Topics

[5.0.6] Fresh Installation Problem

Started by on Oct 05, 2013 – Contents updated: Oct 07, 2013

Oct 05, 2013 22:28    

Hi,

I'm trying to install the 5.0.6, by uploading onto a web server using FTP.

But because of some reason, I'm unable to go past the base configuration settings. I have set the permissions correctly.
In the initial screen the base configuration is entered properly & accepted. After checking new install, again it shows me the base configuration pop up but now all the details are changed backed to default i.e. demouser demopass etc.
I even tried updating the _basic_config.php manually, offline & uploading it back to server, still the same window.
All the screen shots are above.

Earlier it was very easy to install now no idea what I'm doing wrong here. Also when I uploaded the files, _basic_config.php was not there inside the conf folder, it get created afterwords?

Regards,
Abhijit

Oct 06, 2013 00:00

Hello @abhijitkn,

I guess that you forgot to attach the mentioned screenshots. Please upload them and be sure that the URL is visible in the image.

Thanks.

Oct 06, 2013 08:12

Hi Manuel(@mgsolipa),
My bad, I could not attached all the screenshot, so now attaching single pdf with all the info.
This is getting frustrating, first I lost the existing installation, now not able to install the new. :(

Now I get pass the base config screen, but now during installation I get error:
Preparing to install .htaccess ... ERROR!
install/test/index.html was not found as expected.

When I click on continue installation

I get error as: Upgrade failed!

Server PHP version is 5.3.17


Attachments:

Oct 06, 2013 08:42

Hi Manuel(@mgsolipa),

I also tried installing the b2evolution from CPanel, the version is 4.1.4. It installed but I'm unable to log in, showing message as:

Incorrect crumb received!
Your request was stopped for security reasons.
Have you waited more than 120 minutes before submitting your request?
Please go back to the previous page and refresh it before submitting the form again.
Alternatively, you can try to resubmit your request with a refreshed crumb:

Attached is the debugging info.
Can it be server permissions? If yes, then what should I tell it to hosting company?
Also Wordpress could install quite easily from CPanel no errors, pretty straight forward. What could be the issue only with b2evolution?


Attachments:

Oct 06, 2013 12:02

I almost forgot this, please remember to delete your /blogs/conf/_basic_config.php and start all over again.

Oct 06, 2013 14:16

Thanks a lot Manuel.
But I'm not sure if I can edit php.ini.
Multiple times I deleted & uploaded the installation files, also I tried with different FTP client.
I have downloaded the zip file twice.

Everything works fine for the first 2 steps. My base configuration is accepted.
When I click on go to install it as new, the next screen as I get is the Base config recap with all the data incorrect:

MySQL Username: demouser
MySQL Password: demopass
MySQL Database name: b2evolution
MySQL Host/Server: localhost
MySQL tables prefix: evo_
Base URL: http://localhost/b2evolution/blogs/
Admin email: postmaster@localhost

I tried deleting the _basic_config.php but that too didn't help.

I started to think either I move to word press or leave the current hosting provider.
I loved b2e for all the functionality it provides, so trying hard to get it working.

Oct 06, 2013 21:41

Hi @abhijitkn,

The most important thing is that you don't have to think on move to any other system :D

You have two options right now:

1) Ask your hosting provider about your chances on disabling magic_quotes_runtime. Sometimes clients are able to include a directive into a .htaccess file like this: php_value magic_quotes_runtime off. But only they have the answer according their policies.
2) At the moment of the error is produced, your site creates a file named /blogs/config/_basic_config.php. Try to locate each variable and replace their values with your real information. Basically, you must modify these variables:

PHP

$db_config array(
    'user'          => 'demouser',     // your MySQL username
    'password'      => 'demopass',     // ...and password
    'name'          => 'b2evolution',  // the name of the database
    'host'          => 'localhost',    // MySQL Server (typically 'localhost')
);
 
...
 
$baseurl 'http://localhost/b2evolution/blogs/';

After that, you may go back to your browser and press F5, you should be able to continue with the installation proccess.

Oct 07, 2013 07:08

Hi Manuel (@mgsolipa),

I found Php.ini in the public folder & added below code

PHP

magic_quotes_gpc Off
magic_quotes_runtime Off
magic_quotes_sybase Off
register_globals off
allow_url_fopen off

But no help.

I can't change .htaccess otherwise it give me 500 Internal Server Error.

But at the initial screen after entering the base configuration, the installation accepts the settings, but when I click on new install>go it restore the values back to the default. Why is that?
Previously also I tried to replace the variables manually, after which I get the below error:
Preparing to install .htaccess ... ERROR!
install/test/index.html was not found as expected.

Oct 07, 2013 11:13

If you found a php.ini file, then is not necessary to modify the .htaccess. Let's avoid the option 2 that I gave you in my previous comment.

Before to try any fresh install (or upgrade), please be sure that magic_quotes_runtime are set to "Off". You could check that your php configuration takes effect using the phpinfo file included on b2evolution: install/phpinfo.php. Please try to resolve this issue with your hosting provider, after that you will be able to normally perform the installation, and maybe the upgrade that you tried before as well. If you keep getting errors then come back to us.

Thanks.

Oct 07, 2013 20:46

Hi Manuel (@mgsolipa),
Good News!
Finally I got my old blog working. I could log into the back office as well. No security error etc.
What you said was correct, it was the magic_quotes_runtime.
I can install the new version by creating a new php.ini file with the below code:

PHP

Magic quotes
;
 
Magic quotes for incoming GET/POST/Cookie data.
magic_quotes_gpc Off
 
Magic quotes for runtime-generated datae.gdata from SQLfrom exec(), etc.
magic_quotes_runtime Off
 
; Use Sybase-style magic quotes (escape ' with '' instead of \').
magic_quotes_sybase = Off

Refer: http://php.net/manual/en/security.magicquotes.disabling.php
Once the file is saved, copied & pasted into the Install folder & it worked. But I faced errors again (due to Magic quotes) so I left it there & went back to my old blog folder.
Again I copied the same php.ini file in the root folder of the blog, skins, plugins media, & other folders, now the error is no more there.
Just wanted if I do this, is there any disadvantage?
Now I'm writing to my host to switch off the magic_quotes_runtime, let's see. I'll keep you posted.
Finally some peace :)

Oct 07, 2013 21:14

Also in the link abpve it has been mentioned in the comments that
PHP's magic quotes function has the strange behavior of not adding slashes to top level keys in GPC key/value pairs but adding the slashes in deeper level keys. I should have known by the look of the website earlier. ;)


Form is loading...

Blog software – This forum is powered by b2evolution CMS, a complete engine for your website.