Recent Topics

Antispam will not update

Started by on Oct 17, 2019 – Contents updated: Oct 27, 2019

Oct 17, 2019 00:02    

Antispam will not update

@fplanque
I created a new (test) installation of b2evo 6.11.3 specifically to deal with the following problems. This installation is on my production server but is not the production domain. This mimics the same behavior on the production site.

This site has a single collection (blog a), a default installation, and the only changes made were to change the password for admin and to set _advanced.php debug setting to "2". The first indication of a problem is at http://unitedactivision.com/evoadm.php?ctrl=system (see updatedisabled.jpg)
I have no idea where this setting originates

The site can be logged in as:
admin
*** (removed for security)

Feel free to log in and duplicate this behavior.

Goto> features> system
The first indication of a problem is at http://unitedactivision.com/evoadm.php?ctrl=system (see updatedisabled.jpg)
I have no idea where this setting originates.

Goto> antispam> update button
Then, when you then go to the antispam tab and attempt to upgrade, you get the message (http://unitedactivision.com/evoadm.php?ctrl=antispam) (see antispam.jpg)

Since this site is set in debug mode and you can log in to the site, you can see all the debug info.

This behavior occurs on my production site as well. I don't know if this is a bug or not, but I don't know how to fix the problems. Help, Please

Antispam will not update

Oct 18, 2019 01:11

Sorry no help here!
I have tried on my old 6.10.5 and have no problem other than the date of

Updating antispam:
Latest update timestamp: 2014-01-01 00:16:43
Requesting abuse list from antispam.b2evo.net...

which was 2009 before the update, same as what happened with my 6.11.3

In your case b2evo updates are disabled ??

OK Logged into your site.

The first indication of a problem is at http://unitedactivision.com/evoadm.php?ctrl=system (see updatedisabled.jpg)

a) can't get the above url to come up
b) what is updatedisabled.jpg
c) can only guess you may have some strange server setting that is messing with b2evo.
d) I suppose you have spoken to blue host to see if they get the same problem if they install a version?

Oct 18, 2019 11:52

I've been logged in since my last post but access to your site is a problem for me.

I can't get a connection for ages. It took a few minutes just to access >Features I am now waiting for the >System page to be available. I have no data transfer from your site for another few minutes etc.

http://unitedactivision.com/evoadm.php?ctrl=coll_settings&tab=more&blog=1

For example I'm still waiting for data, my current transfer rate is zero . . . . still.

Something on your server is taking a long time to compile a page to send.

This is what happened yesterday. When I try the > System link I get stonewalled ??

OK after 9 minutes I have it and confirm your warning message that b2evo updates are disabled.
Confirm Antispam message

Remote error: No data received from server. (6)

Oct 18, 2019 16:37

@amoun
I guess the slowness is due to the rendering in debug mode.???? Here is the error log for the same site. It would be great if we could see what the call produces at antispam.b2evolution.net Without that info we are blind.

Oct 25, 2019 00:09

This is the response from bluehost as to the antispam problem. I note that this is not an unknown problem to the b2evo community. ie. there is a history https://forums.b2evolution.net/topic-6406. It is their contention that the so called solution in the b2evo code is to repeatedly request antispam.b2evolution.net until you have exhausted the antispam database. They also contend that the transfer of data is limited to 999 records and then fails when the process exceeds that number. This theory conforms to the error_log screenshot in the previous post.

The problem can be duplicated by logging in to http://unitedactivision.com with
admin
debug6113
The installation is a default install of 6.11.3 and is exactly what you get if you use the bluehost install process. I'm astounded that b2evo gurus are not all over this issue.

The debug settings are in place with xml error logging as well.

Oct 25, 2019 03:42

So have you got past the "updates for **** are disabled" error and retreived the list?

My latest and final update after the above mentioned repeated request is 2019-05-05 16:43:57

Oct 27, 2019 02:12

@amoun I have not gotten past whatever is happening on bluehost. They want to blame it on b2evo. I have used the exact same installation on my development server and miraculously it starting working. I have no clue why! (I dowloaded the production code and data) The error log screenshot of the production server is still the same (only different dates)

Once it started, I had to do the update multiple times to get a more current datestamp. Each update produced only 999 new records, which eventually amounted to about 10,000. Then I got a more current timestamp.

As I said, this is on my development server. I plan to export the data back to it's mate on the production machine and see what happens. ie still a work in progress.

What I have learned from this is that there are people updating the central database as recently as 2019-05-05 16:43:57. I have also learned that the spam checking utility use the localhost database and unless you request an update or add a new record the central database is not queried. Also if you add an unreported entry it adds locally and somebody makes a judgement about adding to the central resource.

I never found the links in the forum that you did. They suggest that there may be a hack that resets the datestamp. I am going to explore this. Will be back when I finish the experiment.

BTW, I deleted the unitedactvision.com iteration and just redirected all calls to the main domain.

Thanks, @wrc

Oct 27, 2019 10:17

So it's still a query on why Bluehost seems to say that b2evo updates are disabled ??

I'm wondering if rather than 'disabled' bluehost has blocked acces to the central list by tagging the site as alien.

Associated info
See https://forums.b2evolution.net/topic-22849 about the central list url
See https://b2evolution.net/about/terms-of-service for terms and conditions :)

I note that the central list is at http://antispam.b2evo.net/index.php not https so wonder if that upsets bluehost or something on your installation.

Another thought
RE. The message with the pink background "...... disabled"
It would be a b2evo message so maybe you can look at the source code to see where it comes from etc and chase it back.

Oct 27, 2019 22:45

There seem to be 2 different issues:

1) "Updates from b2evolution.net are disabled!"

Did you use Simple Scripts / BlueHost's inhouse installer?

They probably added something like $allow_evo_stats = false; in one of the config files.

This would not happen if you did a manual install.

2) "No data received from server. "

This means that they probably block outgoing HTTP requests from your server to antispam.b2evo.net.

If you can SSH into your server, try ping antispam.b2evo.net

Thank you for the feedback. We are downgrading BlueHost in our list of recommended hosts.

Oct 27, 2019 23:32

@fplanque (1) the install where that message occurred was their auto install. I have now deleted it The womensvoices.org was a manual install and as you say it does not produce that message.

(2) according to bluehost, they say there is no block on http://antispam.b2evolution.net and I know it is not in the b2evo code. I have an installation on my development server that is identical to the bluehost install that works as it should.

I don't how to do a SSH to bluehost, but I will try to find out how from bluehost.

What is your personal opinion on A2 hosting. I'm tired of trying to get help from Bluehost.
Thanks for your help!

BTW, I am a big fan of b2evo and glad to be part of the community.
@wrc

Oct 27, 2019 23:37

I think A2hosting is much better than bluehost, if only because it uses SSD.

Bluehost used to be better. They have broken many things lately.

I think they don't have a " block on http://antispam.b2evolution.net " indeed. They probably have a block on everything outgoing!

Do you have the same issues with outgoings pings / webmentions?

What about trying to manually enter an URL into auto-upgrade? Will it download a ZIP file from an external server?


Form is loading...

Bootstrap CMS – This forum is powered by b2evolution CMS, a complete engine for your website.